Running VMware vSphere Client on Windows 7

Many of you, like myself, have started running Windows 7 as their primary desktop OS and find it to be a massive improvement over Windows Vista on so many levels.

One of the very few inconveniences I have found with it, and this is not an bug or problem with Windows 7 itself, is the inability to run the VMware vSphere Client.

UPDATE: Good News – This issue has now been resolved in VMware ESX/ESXi 4.0 Update 1 (U1).

When attempting to run the client the following errors are received and you are unable to proceed any further:

“Error parsing the server “<server name” “clients.xml” file.”

 

Error parsing the server “<server name” “clients.xml” file

“The type initializer for ‘VirtualInfrastructure.Utils.HttpWebRequestProxy’ threw an exception.”

The type initializer for ‘VirtualInfrastructure.Utils.HttpWebRequestProxy’ threw an exception

 

Luckily there have been a few good VMware forum posts such as this one by ftubio which outlines how to successfully run the vSphere Client under Windows 7.  I thought I’d put together this brief post with a few screenshots to outline the required steps.

I am running the x64 version of Windows 7 so you will notice that any reference to the ‘Program Files’ will have an ‘(x86)’ at the end of it.  If you are running the x86 version of Windows 7 then ignore the ‘(x86)’ portion of the directory path (ie: C:Program Files (x86) –> C:Program Files).

Follow these 4 basic steps and you’ll be up and running in no time!

Step 1.

imageDownload this DLL called system.dll

*Note:  This DLL is usually found in the  %SystemRoot%Microsoft.NETFrameworkv2.0.50727  directory of a non Windows 7 PC with  .NET v3.5 SP1 installed.

 

Step 2.

Once downloaded install it in the “C:Program Files (x86)VMwareInfrastructureVirtual Infrastructure ClientLauncherLib” directory.  If the ‘lib’ directory doesn’t exist then create it and drop the dll file into it.

VMware vSphere Client Windows 7

Step 3.

Next edit the “VpxClient.exe.config” file which can be found in the “C:Program Files (x86)VMwareInfrastructureVirtual Infrastructure ClientLauncher” directory and add the following three lines to it in the location specified in the screenshot below.  Then save the changes.

<runtime>
<developmentMode developerInstallation="true"/>
</runtime>

VMware vSphere Client Windows 7

 

Step 4. 

From the Windows 7 ‘System Properties’ click the ‘Advanced’ tab and then the ‘Environment Variables’ button as we want to add a new ‘System’ variable.

VMware vSphere Client Windows 7

 

Create a new ‘System’ variable called ‘DEVPATH’ and assign the following variable value:

C:Program Files (x86)VMwareInfrastructureVirtual Infrastructure ClientLauncherLib

 

VMware vSphere Client Windows 7

 

You are now ready to start using the VMware vSphere Client on your Windows 7 machine!  Some people have reported having to run the client as an ‘Administrator’ so if you are having difficulties it may pay to try this – I luckily didn’t experience this problem. Also you will likely have to reboot your machine (or restart the explorer.exe process) for your new path information to come into effect.

 

VMware vSphere Client Windows 7

 

Technorati Tags: ,,,

189 Comments

  1. Since Windows 7 is still in RC Checked Build (checked today on our MSDN subscribtions portal), I’m waiting for the RTM to test this. Since then, VMware might release an update to fix this… I hope… -:).

    Thanks

  2. The instruction was exactly correct, but the System.dll file offered for download at this site was wrong version at least for my system. After failing with the downloaded file (size 2 385 345) I copied the System.dll from a working system (size 3 149 824 bytes) and my system started working.

    • Hi Panu,

      Thanks for letting me know. Is there any chance you could email me your version of the System.dll and I will add that to the article as an alternative?

      Thanks, 🙂

      Simon

  3. Everytime I try this, I get “Configuration System Failed to initialize” Any ideas? I’m running it as administrator and followed all the above directions.

    • Hi Joe,

      It sounds like you may not have the correct path to the DLL added to Windows 7 PC’s Environment Variables. Also bear in mind this path varies depending on whether you have an x64 or x96 copy of Windows 7 install. Did you download and use the DLL from my site?

      Hope this helps,

      Simon

  4. Hello!

    I’m still getting the error after applying this solution. I’m running Windows 7 RTM Ultimate 32bit

    Some one could help me.

    Thanks for this post….

  5. I tried aslezak’s fix for “Configuration System Failed to initialize” error, no luck.

    I checked, re-checked the Lib folder, still no luck. =*(

    Win7 RTM 32-bit

    • Are you running the program as administrator via properties > compatibility? I also set compatibility mode to vista sp2 on my machine. I realize I didn’t add that step to my blog post. If that fixes it, I’ll add it… please let me know either way…

      Also, what do you me you re-checked the lib folder? Can you elaborate?

      • Well this fix worked for me. Setting it into compatibility mode and then running as administrator solved the “configuration System…” issue.

        Thanks for the tip

  6. Works great on Windows 7 Enterprise. Should let VMWare know so they don’t look so stupid just saying yeah we know it doesn’t work…so what…do they really hate Microsoft that much?

    • Hi Mike,

      Good point – though I guess it depends if the PC you do this on is used by multiple users. If just one user then using the ‘user’ environment variable makes more sense.

      Cheers,

      Si

  7. Note that the configuration file should actually have the runtime section first within the configuration section in this order (sorry about the format — commenting limitations):

    configuration
    runtime
    developmentMode
    runtime
    system.net
    appSettings
    configuration

  8. The not being able to run the vsphere client as administrator thing seems to be a permissions issue. I assigned the owner of the lib folder to the SYSTEM user and had it propagate down to the system.dll file, and that seemed to fix the problem for me.

  9. Perfect, once I’d learned how to use my keyboard properly! 🙂 Remeber to log in as an administrator before doing this.

    Great post, thanks.

  10. As noted above in the blog post… you really need system.dll from a NON win7 machine. Just spent an hour with system.dlls from win7’s windowsmicrosoft.net folders.

  11. I also had delete the vSphere client shortcut off the desktonp, and then re add it from “C:Program Files (x86)VMwareInfrastructureVirtual Infrastructure ClientLauncher”. Then it worked

  12. Ok. That does it. x64 Windows has been around for ages. BASIC VMware software doesn’t support iy. (!?).

    What a clown company.

  13. Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you!

    Now it works!

  14. Thankyou for compiling this and making it easy. Now if only they could get a vSphere client that runs natively on Linux my life would be slightly more complete.

  15. You sir rock!

    Thanks for doing this. I was sick of booting XP under Virtualbox! I needed console access to a new datacenter install today. This works perfectly.

    Thanks again!

  16. right on the money. Running w7 Ultimate. Ran through the above steps, which have been made very easy, and the vic runs like a champ, didn’t even require a reboot! awesome job man

  17. For those interested: This fix works for running vSphere on Server 2008R2 as well, although I had to create the “lib” folder as instructed.

    Probably not a lot of people run it on this system, but i thought this may be helpful.

    Great fix!

  18. Two small corrections/updates I’d like to make.

    First, on your step 4, you tell people to use a capital L in Lib, while in step 1 you use a lowercase l.

    So:
    C:Program Files (x86)VMwareInfrastructureVirtual Infrastructure ClientLauncherLib

    Should be:
    C:Program Files (x86)VMwareInfrastructureVirtual Infrastructure ClientLauncherlib

    Not a big deal, but it would be good to be consistent.

    Second, as far as I can tell, you have to reboot after creating the DEVPATH. It would not work for me until I did. Also, the only reason anyone should have to “Run as administrator” is if they set the DEVPATH for USER instead of SYSTEM.

    • Hi Tim,

      Thanks for the comments – good point.

      I have updated the article accordingly.

      I didn’t have to rebooot after defining the DEVPATH though I have made a note in case others do.

      Thanks again,

      Simon

  19. Its important, that you make this lines:

    Thats my fault, why i get the “Configuration System Failed to initialize” error.

  20. I am running Windows 7 also.

    Had installed the 3.5 client installed at first.

    Now i “upgraded” the 3.5 version with the Vsphere client and that works without making any changes as suggested.

    regards.

  21. With Vsphere U1 released 19th Nov 2009, Windows 7 and Windows 2008 R2 are officially supported and vsphere client works straight out of the box.

    Burak

  22. hi, l m getting an error when l do this process. while, when l double click on vmware vsphere client
    l m getting this error:

    CLR Error:80004005
    The program will be end.

    waiting your help.

    best regards…

  23. Ok so after applying this fix (which does work) I noted that all of a sudden it stopped working. But after a reboot it worked again. cannot point to any specific thing that is/was causing it but I went in the the setting and lookaed at teh devpath variable. for some reason it was %program files%….. so I changed it back to c:program files and tada it works again. why it changed is a mystery (windows update perhaps?) but now that it is back it works again
    Thanks
    LP

    • Hi Lester,

      Is your vSphere Client still playing up? Have you looked at upgrading to vSphere 4.0 Update 1 yet as this resolves the Windows 7 incompatibility issue?

      All the best,

      Simon

  24. Hi,

    this article make my life easier…: )
    Until now i have dedicated virtual machine running Windows XP and with vSphere client to manage my ESXI.

    Thank you a lot.

    Klemen S.

  25. If you are able to, install vShpere 4 update 1 (refer VMWare KB article 1011329.) This fixes this and a number of other problems.

  26. THANKS so much for this, Simon. I got my new Windows 7 Dell Latitude E6500 and ran into the problem (because I have not updated my Hosts to U1, yet). Your screenshots made it SO EASY when everywhere else I looked was a sea of text to wade through.

    • Hi Michael,

      Glad this post has come in useful to you and others. I’m personally a big fan of using screen shots and pictures – makes it much easier to follow. Even when writing it. 🙂

      All the best,

      Simon

  27. I tried this and got the “Configuration System Failed to initialize”-error. Then when I looked at the config-file again I realized that the quotes were transformed in the clipboard. Make sure they are XML-compatible quotes and then it works! =)

  28. Great writeup, worked a treat. Had to change the DEVPATH variable though as I had just copied and pasted from yours which of course won’t work on a 32bit OS

  29. This was very useful post.
    I had issue while modifying the file VpxClient.exe.config, since this file is being used by other program (esx client service)…
    All I did is copied the file to a different location & modified as mentioned & replaced the original file with the modified one.

    It worked… Thanks a lot 🙂

    Sudheer Avula

  30. After installing Microsoft’s patches last night my VISTA computer rebooted and I was getting the same error you described for Win 7 users. Your work around fixes the problem on Microsoft Vista machines as well. Thanks

  31. I am running Windows 7 64 bit version. I also had the similar issue when I installed the VVMware-viclient.exe from one of our ESX4 server. I also had VMWare ESXi Free(update 1) on my desktop machine. So I installed tried to download VMware-viclient.exe from VMWare ESXi Free (update 1) installation and to my wonder, it worked with any issue.

    So I recommend to install VVMware-viclient.exe from ESX4 server with update 1.

  32. I followed the steps, but when runnint the client, I got error saying “Please enter a valid server name”. What is wrong here? I used IP address as server name. My system is Windows 7 Professional.

  33. Thanks! This allowed me to get the 4.0 client working on the one Windows 7 machine without having to cause any downtime on the ESX host or risk a failed upgrade.

  34. Hi.
    Gr8 post.. i had spent 2 whole days troubleshooting the same issue. but this article with screenshot really helped me to resolve the same.
    Thanks

  35. Hi, it helps, thanks.
    Btw, may I know why it won’t run properly on win7 without this changes?

    Thanks & regards,
    How Yee

  36. So is the Update 1 take care of the configuration required as described above or do you need update 1 and perform the configuration listed?

  37. I keep coming back to this post time and time again, enough to have committed most of it to memory bar the system.dll download 🙂

    Great work

  38. It worked a treat on my XP pro SP3 PC! The DotNet fix that kept causing the parse error can now be installed!

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.